BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Working with Bookmarks

Define a Bookmark
Place the cursor at the position to bookmark and press Ctrl+F2. The bookmark is signalled by a small green rectangle on the narrow panel on the left from the edited text. It is possible to define as much as 20 bookmarks. Each bookmark has an unique number from 1 through 20. Numbers of deleted bookmarks are reused.
Alternatively, the bookmark can be created by clicking the narrow panel. In this case the position of the cursor in the text doesn't matter; the bookmark will be created for the line that corresponds to the position of the click. The bookmark created this way doesn't contain the information about the column.

Jump to a Bookmark
To locate the bookmark, press F2. Press F2 again to jump to the next bookmark, and so on. Pressing Shift+F2 will jump to the previous bookmark. The order of the bookmarks is determined by the position in the text rather than by its number.
When the bookmark is jumped to, the whole line will shortly blink so that the new position of the cursor can be easily found.

Clear a Bookmark
Place the cursor on the bookmarked line and press Ctrl+F2.
Alternatively, the bookmark can be deleted by clicking the green rectangle in the narrow panel on the left from the edited text.

Clear All Bookmarks
To clear all bookmarks select Find | Clear All Bookmarks from the main menu.
The bookmarks will get cleared also when the file is closed.

 

See Also
Bookmarks