BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Options

The dialog enables to change settings that are common for all Workspaces, for example font and font size of the editor. The other settings are stored to a relevant Workspace.

Paths

Workspace files
It defines a disk location where the Workspace files are stored to. The folder contains one or more *.ws files. The files contain Workspace-specific settings. The path can be either absolute (starting with a disk drive letter), or relative to the currently running ScriptEditor.exe. This path will not be probably changed often. The exception could be a network installation when there is a need to share Workspaces among more users. Showing the path underlined signals that the path already exists.

Script Editor

Syntax uppercase/lowercase
When the option is selected the editor automatically adjusts case of characters of the keywords (reserved words) of the scripting language in use. For example, when the user types
msgbox, the editor changes it to MsgBox. The case of the characters is, however, never changed for case-sensitive languages such as JScript.

Syntax highlighting (colors)
When the option is selected the editor displays different parts of the script in different colors. For example, language keywords are displayed blue, string constants gray, comments green, and so on.

Show syntax hints
As the user types in the editor, upon finishing a name of a known function or method, the editor automatically displayes a small yellow window that suggests parameters of the function. This option determines whether these syntax hint pops up.

Tab size
When the user presses Tab during script editing the current line or the selected block is indented. Pressing Shift+Tab decreases indent of the current line or the selected block. The value Tab size is the size of one indentation in characters.

Editor font
The editor font face and font size can be set here. The default values are marked by the black color in the combo boxes. Keep in mind that it is recommended to use only equidistant fonts such as Courier New for source codes and scripts.

Colors...

The dialog enables to change colors of the syntax highlighting.

Project Editor

Try to create objects while checking Project
When this options is on, then during the project checking the REFERENCE objects are built to prove they are valid. While this is useful for objects like Scripting.FileSystemObject or WScript.Shell, it can cause problems for complex objects like MS Office. These huge OLE objects can take long time to be initialized or they can show parts of their user interface. Keep this option off if such objects are in use.

Use <![CDATA[....]]> for embedded scripts
When this option is on Script Editor encloses embedded scripts to CDATA section so that the content doesn't have to be encoded when an project (*.wsf) file is being saved. Otherwise, characters like "<" are encoded to &lt;, charaters ">" are encoded to &gt;, etc, as the XML format requires.
Temporary files that Script Editor creates for an execution never use CDATA sections in order the Find WSH Error feature can work properly.
Keep in mind that with this option on the Windows Script Host will report different numbers for line and character of an error.

Remove redudant leading spaces and lines
Due to formatting of the XML file, the Project files (*.wsf) that were created in a text editor usually have an empty line at the beginning of the data (embedded <script> elements, <runtime> elements, and similar), as well as white spaces at the beginning of lines (indent in XML file).
When this option is on the redudant empty lines and leading spaces are removed before the content of the element is edited.

Colors...

The dialog enables to change colors the Project tree uses.

Run

Embed all external scripts to Project for Run.
When WSH executes a Project file (Windows Script File, *.wsf), and it fails, WSH reports a line and a column of the problem in the script. This is valid also for external (referenced) scripts. Unfortunately, WSH doesn't report name of the external script in which the problem occured, which makes the information useless.
To work around this, when this option is on, a temporary file with all external scripts embedded is created and handed over to WSH to be executed. When the execution fails, and the line and the column reported by WSH are entered to the dialog of Find Error feature, Editor will find/open the script with error and locates the cursor to the point of the error.

Miscellaneous

Disable Windows screensaver while script is running
It can be inconvenient in some cases that the screensaver is activated while some automation process is running. This option, when it is on, disables the screensaver during the script execution.

Consider numerical values for files sorting
With this option unchecked, the files are sorted like this:
Hello World.vbs
Hello World1.vbs
Hello World10.vbs
Hello World2.vbs
Hello World28.vbs
Hello World3.vbs
With this option check it will look like this:
Hello World.vbs
Hello World1.vbs
Hello World2.vbs
Hello World3.vbs
Hello World10.vbs
Hello World28.vbs

 

 

 

 

See Also
User Interface, Workspace Settings, Understanding Workspaces