BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Menu File

New...

Script - Creates a new script. If more languages are allowed in the workspace settings, the user is given a choice.

Project - Creates a basic skeleton for a project, adding the root <package> element and <job> element.

Project (Wizard) - Creates a basic skeleton for a project, adding the root <package> element, <job> element, and optinally elements like <comment>, <resource>, <runtime>, <object> and <script>.

Open... - Opens an existing file, either a project (*.wsf) or a script (*.vbs, *.js, ...).

Open Script From... - Displays lists of script files to open. It shows also names of all shared scripts from all Workspaces.

Save - Saves the file that is currently selected in the editor.

Save As... - Saves the currently selected file under a different name.

Save All - Saves all the files open in the editor and modified.

Close - Closes the currently selected file.

Close All - Closes all the open files.

Create Windows Shortcut - Creates a Windows shortcut to the currently selected project or script. The shortcuts executes the file by Windows Script Host.

(Files history) - List of files that were recently open.

Exit - Terminates Script Editor. Editor can't be terminated when a script is being executed by the Script Control. Processes executed by Windows Script Host will continue to run after Editor is terminated.

 

See Also
Main Menu, Main Window, User Interface