BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Menu Edit

Remark: black color - item valid for both projects and scripts, red color - valid for projects only, green color -valid for scripts only.

Decrease Indent - Decreases indent of the selected block of the script or the line that contains the cursor. The indent size (number of characters) can be set in Options (item Tab size).

Increase Indent - Increases indent of the selected block of the script or the line that contains the cursor.

Copy - Copies a selected block of a script or one element in the project tree.

Paste - Pastes the copied block of script (scripts) or the tree element (projects).

Make Remark - Marks the selected block of script as a comment, prefixing lines with Rem (VBScript) or // (JScript).

Make Code - Reverts the comment made with Make Remark back to the script.

Auto Complete - If the cursor stands where the user is expected to type a keyword, or a name of a variable, or a name of a method or a property of an object, the function pops up a menu that shows all the possible elements.

Parameters Info - If the cursor stands where the user is expected to write parameters for a function or a method, the function displays a hint window with the help.

Undo - Reverts the last change made in a project or a script.

Redo - Reverts last Undo action.

Edit Element -

New Element

Job - Inserts or adds a <job> element into the project tree. This menu item is enabled only when a <package> element is selected.

Script - Inserts or adds a <script> element, either external or embedded, into the project tree. This menu item is enabled only when a <job> element is selected.

Object - Inserts or adds a <object> element into the project tree. This menu item is enabled only when a <job> element is selected.

Reference - Inserts or adds a <reference> element into the project tree. This menu item is enabled only when a <job> element is selected.

Resource - Inserts or adds a <resource> element into the project tree. This menu item is enabled only when a <job> element is selected.

Runtime - Inserts or adds a <runtime> element into the project tree. This menu item is enabled only when a <job> element is selected.

Comment - Inserts or adds a <comment> element into the project tree. This menu item is enabled only when a <package> or <job> element is selected.

Delete Element - Deletes the currently selected element in the project tree. The element <package> can't be deleted.

Open Embedded/External Script - Opens the script referenced by the selected <script> element. It can be either embedded script (part of the project file, *.wsf), or an external script file (*.vbs, *.js, ...).

Close Embedded/External Script - Closes the script referenced by the selected <script> element.

Make Script Embedded - Copies the content of the external script file referenced by the <script> element into to project file (*.wsf), and changes the <script> element from external to embedded. It doesn't delete the external file.

Make Script External - Saves a script embedded in the project file (*.wsf) to an external script file (*.vbs, *.js, ...), and changes the <script> element from embedded to external.

Move Element...

Make First - Moves the selected element in the project tree to the top of the current branch. The element can't be moved when it is already the first element in the branch.

One Up - Moves the selected element up in the current branch. The element can't be moved when it is already the first element in the branch.

One Down - Moves the selected element down in the current branch. The element can't be moved when it is already the last element in the branch.

Make Last - Moves the selected element in the project tree to the bottom of the current branch. The element can't be moved when it is already the last element in the branch.

 

See Also
Main Menu, Main Window, User Interface