BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Main Window

Main Menu
The standard Windows
main menu to trigger all the functions and options.

Tool Bar
The tool bar with icons of the most used functions and optionally the external user-defined tools for the fast access. The tool bar can be hidden; use the sub-menu View in the main menu.

Command Line Parameters
The parameters that are handed over to the script engine when a project or script execution is started. However, the parameters cannot be handed over when the script is executed with Microsoft Script Control.

Workspace Selection
The combo box enables an easy change of the current Workspace.

File List
It is the list of all projects and script files that are located in the folder as defined by the current Workspace. Double-click the file name to open it in the editor.
VBScript/JScript
It is the list of keywords (reserved words) of the scripting language, as well as constants, intrinsic objects, and similar. Double-click to insert the element into the script in the editor.
Used Objects
The tree control lists objects as defined by the current Workspace. It contains names of the objects as well as their methods and properties. Double-click a name of a method or property to insert it into the script.
WSH
The tree control lists methods and properties of WScript object. Double-click a name to insert it into the script.
(WScript object is available only when the script is executed by Windows Script Host.)

Quick Help Links
The context-sensitive list of direct links to Microsoft help file for scripting (script56.chm). It is possible to add another help file by editing the file ScriptEditor.xml.

Project or Script in Editor
Either a project or a script. The project is displayed as a tree of nodes.

Script Errors
When a script is running and a problem occurs Editor stops the script execution and shows the description of the error. In case the script is executed by the Microsoft Script Control, the red line with the problem description appears here. Click the red line to position the cursor at the point of the problem in the script.
Find in Files
When the function Find in Files is used, usually more occurences are found at a time. Therefore the result appears here in this list. Click the line in the list to open the file, if necessary, and locate the occurence in the script.
Project Errors
Displays list of project errors when the feature Check Project is used. Click the line in the list to locate the problem in the project tree.
Running Processes
Displays list of currently running projects (*.wsf) and scripts. Double-click the line to terminate (kill) the process.

See Also
User Interface