BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Interim Workspace

It is possible to specify a script file name on the command line when Editor is started; this file will be automatically open. See command line options for more details.
If only the file name is specified, and not the Workspace name (typically, the file was double-clicked in Windows Explorer), the Interim Workspace is created.

The Interim Workspace is created in the following matter:

  • All the settings are copied from the Default Workspace
  • The scripts folder is set to the folder where the specified file is
  • The default file extension is extracted from the name of the specified file
  • The language definitions are searched through for the file extension to find a corresponding scripting language

Differences from user-created Workspaces

  • It can't be created by the user
  • It is never saved to the disk as a file
  • The settings are valid only until a regular Workspace is selected
  • When another Workspace is selected files in the editor remain open
  • When another Workspace is selected the Interim Workspace is removed

See Also
Workspaces, Workspace Content, Options, Command Line Options