BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

File ScriptEditor.xml

The file defines the scripting languages in use. To add another scripting language, or to modify the existing ones, edit the file.
There are two blocks <Language name ="name_of_the_language"> in it, one for VBScript and one for JScript. To add another langugage add such a block into the xml structure.

How Script Editor uses ScriptEditor.xml file
When Script Editor is started it searches for the file ScriptEditor.xml in the directory where ScriptEditor.exe file is. If the file is found it is loaded and used. It the file is not found the hard-coded defaults are used instead. Therefore if there is no need to modify the languages definition the file can be deleted.

How to get rid of modified ScriptEditor.xml file
If you modified the file ScriptEditor.xml but you don't want to keep it any more as an extra file, copy it to ScriptEditor.exe file:

type on the command line:
copy /b ScriptEditor.exe + ScriptEditor.xml ScriptEditor.exe

This will add the xml file at the end of the binary file. You can even repeat the process because the xml definition is searched for from the end of the binary file and therefore the definition that was added as the last one will be used.

See Also
Miscellaneous, Workspaces