BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Embedding All Scripts

Select Project | Make All Embedded from the main menu to convert all the external scripts to embedded ones.

During the project development you will probably prefer to keep your libraries as external script files. This will enable you to share this reusable code accross more projects and develop the libraries independently.

When you consider the project is finished, you may need to make the result as compact as possible. Then embedding all scripts is what you need. The result is one, self-containing project file (*.wsf). This file can be run by Windows Script Host. For its run it will not need the external script files any longer.

Keep in mind that by embedding the scripts the names of the original external files will get lost. It is a good idea to keep the project also in the original state to be able to continue in development in the future.

See Also
Run a Project, User Interface