BrineSoft Script Editor
Script Editor - BrineSoft Online Help Prev Page Prev Page
Overview
What Is WSF
Why Use WSF
Scripting Languages
System Requirements
Command Line Options
Errors Handling
Find WSH Error
Bookmarks
Working with Bookmarks
Workspaces
Understanding Workspaces
Interim Workspace
Default Workspace
Workspace Files
Workspace Content
New Workspace Wizard
User Interface
Main Window
Find
Find in Files
Workspace Settings
Options
Object Properties
Replace Selection
Select Jobs
Tools
Select Scripting Language
Create a Windows Shortcut
Get Script File
New Project Wizard
Main Menu
Menu File
Menu Edit
Menu Find
Menu Workspace
Menu Project
Menu Run
Menu Options
Menu Tools
Menu View
Menu Window
Menu Help
Temporary Files
Temporary Files ~$
Temporary Files ~@
Working with Project Tree
Edit <job>
Edit <script>
Edit <object>
Edit <reference>
Edit <resource>
Edit <runtime>
Edit <comment>
Embedding All Scripts
Checking a Project
Working with Files
Open a Project or a Script
Run a Project or a Script
Save a Project or a Script
Close a Project or a Script
Miscellaneous
Microsoft Script Control
File ScriptEditor.xml
Purchase Script Editor
Register the Product
Registration Benefits
 BrineSoft Main Page | Script Editor Page | Download this Help File

Edit <script>

External script file
It is the reference to an existing external script file (library).
Click Get button to pick a an existing file from the current Workspace or from the all Workspaces that share scripts.
Click Browse button to browse for a file with a standard Windows file dialog.
Click Toggle Absolute/Relative button to change absolute path to a path relative to the current Project file (*.wsf), and back.
Type a new name for Script file to create a new external script file.

Embedded script
Select Embedded script to create a new embedded script. The embedded script is a part of the Project (*.wsf) file.
Script preview shows first few tens of characters of the script.

Script language
Select the language of the script. It is particularly important for embedded scripts where the language can't be resolved from the file extension.


Each <job> section can contain one or more <script> elements, either embedded or external. The scripts are executed in the order they appear in the project tree. It is possible to convert embedded script to an external one and vice versa. It is also possible to embed all the scripts at a time (when a project is finished and the file (*.wsf) is sent out).

See Also
Working with Project Tree